Interface

From Valentina Project's Wiki
Jump to navigation Jump to search
This page contains changes which are not marked for translation.

Other languages:
English


When running Valentina, this window opens :


Interface Open.PNG


Open a preexisting file or right-click 'New'.

In a new pattern file, fill in the dialog box which opens, name the pattern piece to create and choose the unit of measurements (cms, mms or inches), right-click 'OK'.

The pattern piece can be named differently afterwards in Pattern Piece → Config Pattern Piece.

Several pattern pieces can be created in the same file in order to display them together in the same layout (right-click 'new patternpiece' in the toolbar) ; note that different pattern pieces are not linked together, so it is not possible to use points and objects from a pattern piece to create points and objects in another pattern piece ; if necessary, create several blocks in the same pattern piece, or use the 'Union tool' in 'Details mode'.

Interface New.PNG


Fill in File → Pattern properties as you like to provide a description of the pattern and technical notes, to restrict access for read only, and provide commercial and technical labels.

Load one of the measurement tables which have been previously created in Tape, see Measurements in Tape.


Then 3 steps have to be achieved :

  • Drafting the pattern in 'Draw mode' ;
  • Choosing the details of the pattern to be last edited, defining pins, nodes, labels, the seam allowance, in 'Details mode' ;
  • Editing the pattern in 'Layout mode' for printing and saving.


Draw mode[edit | edit source]

General rules of drawing in Valentina[edit | edit source]

The new pattern piece is created with a first base point named A, placed at x=0,79375 and y=1,05833. This location and the label point can be changed in the right-sidebar or by left-clicking on point A → Right-click on Options. The label name can also be undisplayed and/or moved in the window.

The second point to add is placed by reference to the first point, by using one of the Tools in Valentina.

As a general behaviour, each point which is placed afterwards is referenced by one or several preexisting points, and objects are created between points.

The tab 'history' displays the list of points and objects in their order of creation ; note that this order may be changed to force Valentina to take into account a created point or object as a reference for a preexisting point or object, but this may be interpreted by Valentina as a mishandling causing unexpected shutdown.

Right-sidebar[edit | edit source]

It displays tool options and group options when the display options are checked in the Toolbar → Pattern properties.


Zoom[edit | edit source]

The pattern view can be sized by using the scale tool placed on the bottom left of screen.

Alternatively, the toolbar provides buttons 'Zoom in', 'Zoom out', 'Zoom fit best current' (optimal view of the whole pattern), and 'original zoom' (tool in Pattern piece → Original zoom, provides a 100 % scale view).


Deleting Points and objects & undoing/redoing previous actions[edit | edit source]

Points and objects can be deleted by left-clicking the item → Delete. Note that points and objects which reference other points or objects cannot be deleted, so the action of deleting several objects or points has to be done from the last one to the first one.

The very last action can be undone by right-clicking on the toolbar button 'undo ...', this can be repeated several times until the expected result is obtained. The tool 'Redo' allows to recreate what would have been undone by mistake.


Details mode[edit | edit source]

Once the pattern is drafted in 'Draw mode', it has to be prepared for its transfer into 'Details mode' using the Workpiece tool, then additionally the Internal path, Pin, Node and Place Label Tools.

Once the pattern has been transfered into 'Details mode', it has to be customized by adding the seam allowance, passmarks, the grainline and placing the labels, see Tools in Valentina-Detail.


Layout mode and printing[edit | edit source]

  • Right-click on 'Layout' mode in the toolbar, and choose the features for displaying and printing in the dialog box ;
  • When the layout is created, you can export it (in the same formats provided when skipping the layout stage) ;
  • Open the printer dialog box in File → Layout → Print ; choose the pdf format if the pattern size is bigger than the printer format, Valentina arranges and cuts each page at the page format specified by the user.